Checking OttoUpdate Version

Your web browser is not supported
The myOtto website requires the use of an ActiveX control in order to communicate with your device.


Please make sure you are using Internet Explorer version 4.0 or higher when configuring your Otto.
Firefox or Opera browsers are not supported at this time. For IE10, ensure that the website is added to the websites listed within the compatibility view (Tools --> Compatibility View Settings).

Copyright 2007-2013 PERSENTECH Inc.
All Rights Reserved
OttoUpdate Software Version:
Unknown
www.myottomate.com